HairlesMonkyBoy

Squeeze more FPS out of your Nvidia Card

20 posts in this topic

This will work especially well for people who are bottle-necked by their CPU. Since this game is highly single threaded, that is likely a large portion of people. This seems counter intuitive, "How can changing settings on my GPU help me with a CPU bottle-neck?" But, because your GPU isn't being used near the edge of its ability, your system may be throttling its frequency which could be limiting your FPS even further than the CPU bottleneck already was.
 
How I came Across This:
 
You can honestly skip this part, but for those who are curious/bored.


As some of you may know, I've been recording games and putting them on youtube and adding them to my thread in the Purple Poaster Replay PlaceI started doing this in version 9.6, and I found that I could record games at 1080p at an unwavering 30fps with the game settings maxed out. When 9.7 came along, I found that my replays would no longer record at 30fps, instead they would drop to 18 and lower while recording. My first thought was, since I use SLI, that WG broke SLI support again, so I tried disabling SLI while recording and this seemed to fix the problem (in retrospect this was not actually the problem). But, I was still getting frame rate drops down to the lower 20s despite my GPU and CPU usage being ~60% and ~50% respectively. This was irritating to say the least, so I investigated further.
 
What I found was that while I was playing back and recording the replay, my GPUs clock frequency was not at its mximum of 1215MHz, instead it was getting throttled to something like 840MHz. When I had SLI enabled, the usage of my GPUs was even lower, ~30%, and the clock frequency was throttled even lower. This resulted in the 18fps that I was seeing. Installing the update must have reset my Nvidia Control Panel Settings. I must have set the power management mode to prefer maximum preformance at some point in the past without realizing the implications.

 
The Fix:

Fixing the problem was as simple as adjusting the power management mode in the Nvidia Control Panel. Turning on maximum performance mode locks the GPUs clock frequency at its maximum, in my case 1215MHz, unless of course the card is using too much power or is becoming overheated. For those of you who don't know what I'm talking about, I've prepared a little tutorial below:

 


1. Open The Nvidia Control Panel by right clicking on your desktop.

dlvctKe.png



2. Click on "Manage 3D Settings" in the left column.

DERa0cG.png



3. If you want to make these changes Globally to all of your games and applications, find the "power management mode" setting in  the "Global Settings" tab and select "Prefer maximum performance". You are done! If you want to make this change for only WoT or other games individually skip to step 4.

HLh6Yvb.png



4. Click on the "program Settings" tab and then the "Add" button.

rDVCguL.png


 
5. In the "Add" menu, select "World of Tanks" or any other game/program on your PC.

48eQoqI.png


 
6. Find the "power management mode" setting and select "Prefer maximum performance". Done.

I4Y4GKr.png



 
Doing this helped me record games at a constant 30fps and it also allowed me to get 10% to 20% more fps in-game aswell. Hopefully this helps some of you achieve similar results. Changing some of the other settings in the Nvidia Control Panel can help weaker systems achieve better performance at the cost of image quality.

Share this post


Link to post
Share on other sites

Thanks, just tried it with WoT and I see a slight improvement. I'm gonna try this with AW too.

Share this post


Link to post
Share on other sites

As an aside, I have been suffering from random unexplained CTD in 9.7, but I seem to have fixed the problem by running WoT through GeForce Experience. 

 

I spoke too soon. :/ 

Share this post


Link to post
Share on other sites

Done, and while I was at it, I noticed it was in a multiple monitor performance setup. So I switched it to single monitor performance as well. Hopefully that provides a nice increase.

Share this post


Link to post
Share on other sites

isn't it amazing what we have to do to make this game run half decently, just because WG just either cant/wont.

 

When i play (used to) WT on high, i never dip below 60 fps, thats with shit exploding everywhere and it tops of at near 100fps... WoT on medium settings, well i get from 30 to 60fps depending on the map, on the same goddam computer.

Share this post


Link to post
Share on other sites

so I just had a look at it on my second, non gaming PC. with a GT630, I dont have that setting option?

 

I did also notice I was in a multi monitor setup, so I switched that as well.

Share this post


Link to post
Share on other sites

so, I turned it on. I havent checked it with anything else yet, but on GTA5, it removed the stuttering I was getting with it occasionally....but put a 60fps hardcap on, compared to my usual 100+?

Share this post


Link to post
Share on other sites

I upgraded from a Core 2 Quad on an HP OMC mobo to an Asus with a Z97 chipset and an I7 4790K... It more than quadrupled my framerate from 30ish to 140ish (then I turned up graphics settings until it sat around 60).

 

Though, I already turn everything I put into my computer to max performance... who wants to save electricity?

Share this post


Link to post
Share on other sites

so, I turned it on. I havent checked it with anything else yet, but on GTA5, it removed the stuttering I was getting with it occasionally....but put a 60fps hardcap on, compared to my usual 100+?

Vsync does that, not the performance mode. You may have changed it in the Nvidia Control Panel by mistake.

 

Related: If you are going to use vsync, I find that it is usually better to use the in-game setting rather than the Nvidia Control Panel because the Nvidia Control Panel Vsync seems in general to use a lot of CPU power.

 

I upgraded from a Core 2 Quad on an HP OMC mobo to an Asus with a Z97 chipset and an I7 4790K... It more than quadrupled my framerate from 30ish to 140ish (then I turned up graphics settings until it sat around 60).

 

Though, I already turn everything I put into my computer to max performance... who wants to save electricity?

 

Well, shit!

Share this post


Link to post
Share on other sites

Vsync does that, not the performance mode. You may have changed it in the Nvidia Control Panel by mistake.

Related: If you are going to use vsync, I find that it is usually better to use the in-game setting rather than the Nvidia Control Panel because the Nvidia Control Panel Vsync seems in general to use a lot of CPU power.

Well, shit!

nope, hadn't touched it.

I turned the power management thing back off and it bumped back up to 100.

Share this post


Link to post
Share on other sites

Mmkay, I'll give it a whirl! I know I have an average of 58-65 fps when running moderate to high settings in WOT. My graphics card is an GeForce GTX 750Ti. Just changed the settings and will take my tank out for a spin to see if I see any change.

Share this post


Link to post
Share on other sites

nope, hadn't touched it.

I turned the power management thing back off and it bumped back up to 100.

That seems very odd to me. There is almost definitely something else going on here.

 

Fogremover helps with the FPS aswell.

I use this mod as part of Aslain's mod pack. The version of it in there also reduces the lag when switching between sniper and third person view. I believe it's called max farplane.

Share this post


Link to post
Share on other sites

Mmkay, I'll give it a whirl! I know I have an average of 58-65 fps when running moderate to high settings in WOT. My graphics card is an GeForce GTX 750Ti. Just changed the settings and will take my tank out for a spin to see if I see any change.

 

Zero improvement. Played all evening in different modes and all, and had same rate. But it's fine, I'm not having shit FPS anyway. :D

 

I also use fog remover, so much easier to do skillshots like this:

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.