Sign in to follow this  
yoyoya2

Laptop shuts off when trying to game on battery or under load

6 posts in this topic

So I have a MSI gs60 2pe and about a year ago I got a new battery for it and i've never been able to game on it when it's on battery

This is annoying as sometimes i pull the power cord out and it will randomly shut down. It will also randomly shutdown during startup or when I close the lid and I have no way of knowing when. 

When this shutdown occurs I hear a small beep and the battery light flashes amber. Often I can only restart the laptop when it's plugged in. This has nothing to do with battery capacity as I am averaging a good 3-4 hours of battery life which is normal for this laptop. I'm guessing it's more of a case of the battery not being able to release enough power when under load. 

Here are all my battery reports  and the battery model is BTY-M6F

https://ufile.io/rmb7y

 

https://ufile.io/bg7d1

 

Should I get a new battery, they're not terribly expensive so I don't mind but I want to make sure that's the problem

Share this post


Link to post
Share on other sites

The battery should be able to run the laptop under load. It may be an issue with settings that when the charger is unplugged, it switches to power-saving mode and therefore causes shutdowns.
This would be my initial suspicion due to the fact that you are able to run 3-4h with the battery. Right click the windows taskbar --> search --> Control Panel --> system + security --> power options and show us your settings on the main menu and advanced power settings.

Share this post


Link to post
Share on other sites
On 11/2/2018 at 7:35 PM, Fulcrous said:

The battery should be able to run the laptop under load. It may be an issue with settings that when the charger is unplugged, it switches to power-saving mode and therefore causes shutdowns.
This would be my initial suspicion due to the fact that you are able to run 3-4h with the battery. Right click the windows taskbar --> search --> Control Panel --> system + security --> power options and show us your settings on the main menu and advanced power settings.

CshsG1V.jpg

I'm basically running at the balanced settings, when I'm plugged in it's at max performance and when it's not it's at better battery

Share this post


Link to post
Share on other sites

Sounds like a hardware fault, maybe with the hardware that detects charge level or maybe battery temperature mis-reporting and triggering a shut-down. If your battery is holding a charge then I'm not sure a new battery will help. You might need to return the laptop to MSI for repairs.

Share this post


Link to post
Share on other sites
8 hours ago, OOPMan said:

Sounds like a hardware fault, maybe with the hardware that detects charge level or maybe battery temperature mis-reporting and triggering a shut-down. If your battery is holding a charge then I'm not sure a new battery will help. You might need to return the laptop to MSI for repairs.

damn that's what I was afraid of, Guess i'll just have to live with it until I get a new laptop

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.