Jump to content
It's_Matra

[0.9.19] MatraMod Customisable Vanilla Modpack [Updated 28/04/17]

Recommended Posts

Thanks for making this modpack (and for directing me towards your mod pack in another thread).

 

I really like it, and have so far been the best I've used since Selas. Since installing this I've played 20ish games without any crashes.

 

(also a special thanks for the noscroll update, edited the default zoom to 1.0 easily aswell)

 

 

Share this post


Link to post
Share on other sites

Thanks for the feedback, it's all designed to be as easy to use and modular as possible allowing those to either change settings with no experience or use it as a basis to learn basic xvm config editing.

It's generally updated on patch day in bits then I test it all together or wait for stable releases before releasing the all-in-one modpack. This means that those in a rush can still have some of the mods/features that they like and those who do not wish to download things individually can just wait 2-3 days for the full pack :)

Share this post


Link to post
Share on other sites

Battle assistant don't seem to work. Without cameranode and _init game doesnt start at all, and with the ones in the mod, game crashes at login. 

I have updated the link so try again.

First time I haven't used physical hardware (USB Drive) to move files around (using a cloud based file system for editing now). It's possible there was a sync issue... see how you get on with the updated link

Share this post


Link to post
Share on other sites

Updated more mods to 9.10

Autoaim+ updated to 9.10, also now does not cycle between tanks on right click (if within target area), this was a bug and is now fixed

Zoom Mod v1.1 added option to force disabling of dynamic camera rather than just using in-game settings, this will allow you to use the horizontal stabiliser option in game without the dynamic camera.

XVM config has a few small bugs (XVM related) and will be updated soon, all other mods tested and working well

 

Modpack will be combined once the XVM bugs have been fixed, there are a few that have been already but still needs some more tweaks, this should be later today or tomorrow (all going well!)

Share this post


Link to post
Share on other sites

I'm away for a week so if a stable version of XVM comes out just download it from the XVM website and install as normal, it won't upset any of the mods. I'll release the full pack along with some XVM tweaks when I return

Share this post


Link to post
Share on other sites

Hi Matra, the newest version of the modpack doesn't work for me. Although XVM loads, it runs at default settings. My settings from the "alternatives" folder don't load. The modpack version from a week ago worked fine.

Share this post


Link to post
Share on other sites

Hi Matra, the newest version of the modpack doesn't work for me. Although XVM loads, it runs at default settings. My settings from the "alternatives" folder don't load. The modpack version from a week ago worked fine.

Hmmm that's odd... I only changed the colour. I'll look into it and see if there have been any major changes inside of XVM (I am a week behind!) In the meanwhile if you need the older version it's here

Just re-uploaded the 'new' version which should fix the issue... looks like a feature was added and then removed before the stable release

Edited by It's_Matra

Share this post


Link to post
Share on other sites

Thank you! I did a clean install of WoT, but now neither the new nor the older version of the pack work for some reason.

There's an error showing up:

ERROR: [ERROR] (scripts/client/gui/Scaleform/framework/entities/BaseDAAPIModule.py, 60): Error during <gui.Scaleform.framework.managers.TutorialManager.TutorialManager object at 0x36235330> flash disposing

I'll retry with future versions of your modpack and/or WoT. There's no other quality and customizable pack that doesn't include obtrusive stuff such as overtarget markers.

Share this post


Link to post
Share on other sites

Thank you! I did a clean install of WoT, but now neither the new nor the older version of the pack work for some reason.

There's an error showing up:

ERROR: [ERROR] (scripts/client/gui/Scaleform/framework/entities/BaseDAAPIModule.py, 60): Error during <gui.Scaleform.framework.managers.TutorialManager.TutorialManager object at 0x36235330> flash disposing

I'll retry with future versions of your modpack and/or WoT. There's no other quality and customizable pack that doesn't include obtrusive stuff such as overtarget markers.

That's interesting as that's the error you get if you use an outdated version (9.9) of tehHedger's/Locastan's radial menu...

Is that the only error you are getting? It shouldn't stop the pack from working at all... does an error message pop up during the battle loading screen? (at the bottom where gametips normally are)

 

EDIT: Found a possible bug in the bit that has been causing me the most annoyance lately, hopefully fixed it and trying something new too with this update... possibly new coding efficiency :P

(updated link in the first post)

Edited by It's_Matra

Share this post


Link to post
Share on other sites

Updated XVM config and modpack to fix all the little bugs along with updating to latest stable version of XVM. I've learnt a cool new trick with configs which I will be looking at applying across all options (smaller config size whilst retaining the customisability of this pack).

 

Share this post


Link to post
Share on other sites

Is that the only error you are getting? It shouldn't stop the pack from working at all... does an error message pop up during the battle loading screen? (at the bottom where gametips normally are)

...

Sorry about the late answer. I'm getting some more errors in my xvm log. Maybe I'm having problems with OMC modpack that I've used before. Even if I empty the res\mods folder, OMC saves some files into windows\fonts, for example. Here's the xvm log, in case you're interested: http://www.mediafire.com/download/0zccblr94de3hax/xvm.log

Share this post


Link to post
Share on other sites

Sorry about the late answer. I'm getting some more errors in my xvm log. Maybe I'm having problems with OMC modpack that I've used before. Even if I empty the res\mods folder, OMC saves some files into windows\fonts, for example. Here's the xvm log, in case you're interested: http://www.mediafire.com/download/0zccblr94de3hax/xvm.log

That was very helpful. It helped show a bug that is fixed in my next release for 9.10 (fixed it without knowing it was an issue!) so there is a config fix in the first post or download it directly here 

Replace your existing login.xc with the one linked and will include this (along with other changes) in the 9.10 release

 

Lots of stuff to work on for 9.10 :(

 

Share this post


Link to post
Share on other sites

I get something really weird. I installed some alternative files like no hitlog and I wanted the minimap with the 50m proxy spot circle and the bigger minimap with CTRL key. Despite all the files being correct as far as I can tell, the game completely ignores that. The bigger minimap doesn't work, the 50m spot circle doesn't show up, the hitlog is STILL displayed. Auto login doesn't work either.. and double carousel no joy.  Its like the standard version works, yet anything alternative the game ignores. Despite restarting!

I installed the damage panel as well, the english version works, the NA version gives me "error: text formatting" on the damage log.

Any ideas?

Edit: I do get this weird looking line in the XVM log:

2015-11-04 00:40:19: [JSONxLoader] load: res_mods\configs\xvm\MatraModSettings\hotkeys.xc
2015-11-04 00:40:19: [JSONxLoader] load: res_mods\configs\xvm\MatraModSettings\login.xc
2015-11-04 00:40:19: [ERROR] Traceback (most recent call last):
  File "xvm_main/config.py", line 104, in _load_xvm_xc
  File "mods/xfw/python/lib/JSONxLoader/__init__.py", line 9, in load
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 25, in load
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 44, in visit
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 69, in visit_dict
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 44, in visit
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 69, in visit_dict
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 44, in visit
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 52, in visit_dict
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 52, in <dictcomp>
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 44, in visit
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 58, in visit_dict
  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 38, in load_config
JSONxLoaderException: PAIR: <pair> expected, got "}" at 9:2 in "res_mods\configs\xvm\MatraModSettings\login.xc"

2015-11-04 00:40:19: [JSONxLoader] load: res_mods\mods\shared_resources\xvm\l10n\en.xc
2015-11-04 00:40:19: Config loaded. Region: NA (detected), Language: en (detected)
2015-11-04 00:40:19: WARNING: TODO: len(hulls) != 1 for vehicle germany:PzVI
2015-11-04 00:40:21: [X:000] onLibLoaded: ../../res_mods/mods/packages/xvm_main/actionscript/xvm_main.swf

But I can't quite figure out how to fix that..

Share this post


Link to post
Share on other sites

Have you applied the login.xc hotfix on the first post? I would update the whole modpack but it's in preparation for 10.0 at the moment so a hotfix was supplied.

 

I'll look into the NA damage panel settings and the other issues sound like you don't have the login hotfix applied... the weird xvm errors are related to the python scripts that haven't been updated yet and does not affect anything. To update just download and install the latest XVM version from their site (doesn't affect your settings), copy the vehicleNames.xc from the default folder and paste into MatraModSettings to ensure that is up to date too. (Can't remember if any new vehicles added since release).

EDIT: There is indeed a small issue with the NA config, I will work on this tonight if I can and get an update ready for tomorrow. I will try and cram in the other bits I wanted to do before 10.0 but in the meantime if you want to fix it yourself, open the Log.cfg file and replace the "format" section with this

        "format" : {
            "text" : "<textformat tabstops='[72,110]'><font color='#CCCCCC' size='14'>{numberLog:>4}. <b>{damagesHit}{criticalHit}{splashHit}</font></b><tab><font size='17' color='{reasonHitC}'>{reasonHit}</font></textformat>",
            "alttext" : "<textformat tabstops='[72,110]'><font color='#CCCCCC' size='14'>{numberLog:>4}. <b>{damagesHit}{criticalHit}{splashHit}</font></b><tab><font size='17' color='{reasonHitC}'>{reasonHit}</font></font></textformat>"
        },


 

Share this post


Link to post
Share on other sites
1 hour ago, It's_Matra said:

 but it's in preparation for 10.0 at the moment

 

:wut:

you mean 9.12? or are you so loti super we will be getting modpack for non existing patch :doge:

Share this post


Link to post
Share on other sites
31 minutes ago, Visn0r said:

:wut:

you mean 9.12? or are you so loti super we will be getting modpack for non existing patch :doge:

:rngfu: pedantic mofo

 

Yes 9.12 'minipatch' will be the next release.. providing things don't go seriously wrong... personal circumstances have meant I'm going to be rather busy for a while... especially for this month! (November)

Share this post


Link to post
Share on other sites

I tried the login hotfix yes, didn't fix the general issues. I also updated XVM while keeping all of your config files without success either.

I don't understand for instance why it would draw the dynamic and max view range circles, but not the 50m one. Its the same file, same syntax.. yet one draws, the other doesn't?

Or the carousel stuff. Its just really weird.

Thanks for looking into it, I really like your modpacks balance between adding useful info and being "clean".

Share this post


Link to post
Share on other sites

The proxy circle is enabled by default... what it may be actually (coming to think of it) would be the 'new' way that the minimap now works in later version of XVM (released after this pack) which 'could' mess things up... I'll have a look into that but it would take a while longer. Damage panel first then I'll come back to the XVM issues :)

 

Share this post


Link to post
Share on other sites

I just followed al the steps you described and with the fixed login.xc I still get the

  File "mods/xfw/python/lib/JSONxLoader/loader.py", line 38, in load_config
JSONxLoaderException: PAIR: <pair> expected, got "}" at 9:2 in "res_mods\configs\xvm\MatraModSettings\login.xc"

Is there a syntax error somewhere? I don't know anything about coding so I can't find it.

I changed the damage log as you said and it now works. Thanks!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...