Jump to content
It's_Matra

[0.9.19] MatraMod Customisable Vanilla Modpack [Updated 28/04/17]

Recommended Posts

Been trying out your pack and I seem to have a problem when zoomed in the screen starts to lag, Running nothing else  running 55 fps computer is brand new, any thoughts?

 

Share this post


Link to post
Share on other sites
11 hours ago, Heavyshot said:

Been trying out your pack and I seem to have a problem when zoomed in the screen starts to lag, Running nothing else  running 55 fps computer is brand new, any thoughts?

Are you using the complete pack or an assortment of individual mods? The pack contains a new zoom which causes less fps drops than the standalone one.

I run WoT on a potato laptop and get barely noticeable changes in fps when zooming in, if zooming in to special effects such as smoke/fire (mostly smoke!) then your graphics card will be stressed more and could cause fps drops if it's not up to the job...

May not be the issue but it can happen.

Share this post


Link to post
Share on other sites

complete pack. Have not had an issue zooming in and getting lag except on yours I will go back through and reloaded it and see. .

Share this post


Link to post
Share on other sites

Hey Matra!

Still a happy user of your modpack, I just get one odd bug. I can't add camo with it! When I open the "exterior" screen its blank at the bottom and I can't add camo.

Any ideas?

Share this post


Link to post
Share on other sites
On 19/02/2016 at 1:14 AM, Nalok said:

Hey Matra!

Still a happy user of your modpack, I just get one odd bug. I can't add camo with it! When I open the "exterior" screen its blank at the bottom and I can't add camo.

Any ideas?

Any details? Any tank or just the czech ones?

There is a bug in xvm to do with the czech camo which will be fixed in the latest/next release. :)

 

Share this post


Link to post
Share on other sites

I used to have the same issue, but when I redownloaded xvm it got fixed. I believe it's the version of xvm (not just the config, but the ui files in /0.9.13 and /mods). The only way to update those is by downloading the most recent xvm from their website. My guess is Matra's modpack still uses an older version of xvm if you're getting those issues.

Share this post


Link to post
Share on other sites
2 hours ago, SZXT77 said:

I used to have the same issue, but when I redownloaded xvm it got fixed. I believe it's the version of xvm (not just the config, but the ui files in /0.9.13 and /mods). The only way to update those is by downloading the most recent xvm from their website. My guess is Matra's modpack still uses an older version of xvm if you're getting those issues.

Seems that was it. Updated XVM and the problem goes away!

Best modpack NA ;)

Share this post


Link to post
Share on other sites

Hi All,

Sorry support has been rather lax lately, sadly a lot of RL stuff is taking precedence (as it should!) so it may take me a while longer than normal to get everything updated/tested and released again.

I will be continuing to keep this updated the best I can, the damage panel seems by FAR the most popular part of the modpack so I will be prioritising that first.

Working on new 'slimmer' version of the XVM config which also merges the slimline config into the existing one. I have started playing without XVM stats so adapting the 'slimline' config to be even better - might even 'rebrand' it

Share this post


Link to post
Share on other sites

All good to go bar the BattleAssistant mod. Not yet tested with 9.14 (lack of time!)

Some changes to the xvm config as it's slowly being designed to work more as part of the 'pack' than on it's own. The Hitlog is no longer shown by default (option to enable) but remaining enemy HP still works.

This is due to the updates on the Damagelog which makes the XVM hitlog redundant.

Other changes include: 

Reworked tooltips and now shows more information including crew layout
Smaller size than ever before (for XVM config and modpack)

 

Share this post


Link to post
Share on other sites

Have you got the enemy/team hitpoints left mod working?

Share this post


Link to post
Share on other sites
7 hours ago, Nalok said:

Have you got the enemy/team hitpoints left mod working?

Spotted enemy hitpoints is working

If you're after a whole team HP bar then that's not included in the modpack

Share this post


Link to post
Share on other sites
17 hours ago, It's_Matra said:

Spotted enemy hitpoints is working

If you're after a whole team HP bar then that's not included in the modpack

Thats the mod I was after! It's still showing on the screenshots in the OP. Guess I'll have to dig that up somewhere.

Share this post


Link to post
Share on other sites
14 hours ago, Nalok said:

Thats the mod I was after! It's still showing on the screenshots in the OP. Guess I'll have to dig that up somewhere.

Is it? I can't see it... o.O

Share this post


Link to post
Share on other sites
11 minutes ago, It's_Matra said:

Is it? I can't see it... o.O

It isn't.. I mistook the arranged icons for the HP bars. But it should be damnit! ;)

Sorry to waste your time looking, I guess I need my eyes examined...

Share this post


Link to post
Share on other sites

Don't know if I did something wrong, but using the option to disable the XVM minimap also disabled all of the XVM-like features on the vanilla minimap as well.  This wouldn't normally be a problem, but the XVM minimap features were not working properly (missing circles, tank VR circle was obviously wrong, etc).  I managed to get the minimap working properly by deleting all of the minimap files in the xvm config as a test, but this also (as expected) broke some of the other XVM features.

Normally I figure I'm competent enough to figure things out on my own, but this one has me stumped.

Share this post


Link to post
Share on other sites
11 hours ago, Spyshadow01 said:

Don't know if I did something wrong, but using the option to disable the XVM minimap also disabled all of the XVM-like features on the vanilla minimap as well.  This wouldn't normally be a problem, but the XVM minimap features were not working properly (missing circles, tank VR circle was obviously wrong, etc).  I managed to get the minimap working properly by deleting all of the minimap files in the xvm config as a test, but this also (as expected) broke some of the other XVM features.

Normally I figure I'm competent enough to figure things out on my own, but this one has me stumped.

You couldn't set any of the options in the main game menu when using the disabled config?

That might be a bug in XVM, will look into it when I get the chance.

As for the minimap features not sure what is going on there as that part is a carbon copy of what I currently use. You can try updating it by downloading the latest version of XVM to see if that fixes anything (won't mess up your config)

19 hours ago, Nalok said:

It isn't.. I mistook the arranged icons for the HP bars. But it should be damnit! ;)

Sorry to waste your time looking, I guess I need my eyes examined...

Hahahahahaha, no worries, had me looking for it too!

 

 

There will be an updated version of the config released later this week as I just can't stop tweaking things to make them look better (especially as I know play without XVM stats - really enjoy the game more!)

Share this post


Link to post
Share on other sites
2 hours ago, It's_Matra said:

You couldn't set any of the options in the main game menu when using the disabled config?

That might be a bug in XVM, will look into it when I get the chance.

I could set them, but no matter what options were selected the minimap showed no additional information (no tank names, no circles).

2 hours ago, It's_Matra said:

As for the minimap features not sure what is going on there as that part is a carbon copy of what I currently use. You can try updating it by downloading the latest version of XVM to see if that fixes anything (won't mess up your config)

I'll give that a try.

EDIT:  Updating XVM had no effect, will play around with a few things to see if I can find anything else.

EDIT 2:  It seems that something in XVM is forcing the expanded minimap features to be disabled.  They seem to default to "Never" and any time they are set to anything else the immediately default back to "Never."  This happens even with the disabled minimap, meaning that none of the features are active with this config.

EDIT 3:  Apparently I'm a moron, and the "missing" XVM minimap features are activated by using the "alt" key.  Is there any way to make it so that these features are always active?

Share this post


Link to post
Share on other sites
2 hours ago, Spyshadow01 said:

I could set them, but no matter what options were selected the minimap showed no additional information (no tank names, no circles).

I'll give that a try.

EDIT:  Updating XVM had no effect, will play around with a few things to see if I can find anything else.

EDIT 2:  It seems that something in XVM is forcing the expanded minimap features to be disabled.  They seem to default to "Never" and any time they are set to anything else the immediately default back to "Never."  This happens even with the disabled minimap, meaning that none of the features are active with this config.

EDIT 3:  Apparently I'm a moron, and the "missing" XVM minimap features are activated by using the "alt" key.  Is there any way to make it so that these features are always active?

That is some insanely helpful information so thank you for that, I have isolated the issue and fixed it from your help alone :)

It will be fixed in the next release - later this week

 

If you want to fix it yourself edit the 'disable minimap config' to be the following

{
  "minimap": {
    "enabled": false,
	"useStandardCircles": true,
    "useStandardLabels": true,
    "useStandardLines": true
  }
}

 

Not sure why the formatting has gone all funny there, but you get the idea! (The introduction of circles into the in-game options caused an issue so thank you very much for your help with that! The only way I can fix things is if people tell me what is wrong!)

Share this post


Link to post
Share on other sites

Hoped to have a new release by now but having issues removing the XVM sounds and keeping the stock ones (apart from fixing Rudy!)

Also upcoming are some changes.. option to enable team total HP

Total_HP.png

 

but the biggest change is in the layout (more noticeable on the streamline config - how I now play without stats/colour)

Clan tags for left side have been moved to precede the name adding a line of symmetry. The clan tags are also slightly less opaque making identification of clan/name that little bit easier

panels.jpg

I will also be adding the 'last shot' for the damagelog to be the default setting, I've found it to be quite useful.

I'm hoping I can find a fix for the sounds issue early next week so I can release all the new cool tweaks

Share this post


Link to post
Share on other sites

d1ec5551ffaffd653190cf01f344fe25c6c4f0d8

 

I have indeed fixed the sounds issue so Rudy is now back! (yay!) All of the other nice, fancy new sounds remain too (not using the horrible XVM sounds... In-game ones are WAY nicer!)

Also going to be releasing the Zoom Out/Freecam mod on it's own to supplement other modpacks as the standalone zoom mod I'm discontinuing support for. Barely anybody downloaded it and if you want a vanilla zoom mod then use my XVM config with the streamline option(s).

I will be uploading the new stuff tomorrow [with another announcement] as it's late and my wife is moaning

Share this post


Link to post
Share on other sites

New Addition:

ZOOM OUT AND FREECAM MOD

What is this?

Well it's a simple mod to give you more zooming out range to my defined settings but also allow you to use freecam in replays to make your own videos or just get a better look at certain situations.

Why would I want to use this?

Well I don't know, you wouldn't be reading this if you didn't want to use it. For the sake of comparison, most zoom out mods such as that of Quickybaby's 'modpack' zoom out WAY too far, this one does not. It is completely compatible with Quickybaby's modpack (and most others that don't use PMOD, it may work with PMOD but untested) and will give you the added benefit of the freecam when reviewing replays.

How do I use this?

Well installation instructions and instructions for use are included, if you lose them there is a freecam guide on the first post of this thread

54737190.jpg

The XVM config is finally in a usable state so have updated it, fixing the Rudy sixth sense sound! (yay!) and a few other small tweaks along the way 

Share this post


Link to post
Share on other sites

As I'm being PM-d in game by a LOT of you, here are step by step instructions to get the mods working for 9.14.1

 

Copy 9.14 folder contents to 9.14.1

Update XVM http://www.modxvm.com/en/download-xvm/

 

Done :P

 

Share this post


Link to post
Share on other sites

So, the right click drop down menu in the contacts bar isn't working anymore.  It works fine with all mods removed, but with the modpack up it does not work except for those you already have in the "blacklist" or "recruit" sections of your contacts.  Unlike the minimap issue I had earlier, I have no idea where I should even start to try to troubleshoot this.

EDIT:  Disregard, newest version of XVM fixed this issue.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...