Jump to content
Victrix

**FIXED** Motherboard/CPU errors and fails

Recommended Posts

So my CPU died on me today. Computer just shut off and wouldn't power up again. PSU works fine so I figured it's the CPU after troubleshooting.

I plan on upgrading from the i3 that died to an i5, how should I choose it model wise and how do I buy the correct socket CPU? Obviously going for budget here because I'm poor as fuck, but I don't want it to break o n one year either. This one lasted me a good 6-7 years.

Link to post
Share on other sites

Well first off I would look and see what your motherboard is and then google it to find the socket.

If I would guess it would be LGA 1150 from the year that you said in post, but check.

Then when you shop it will say what the socket is on box or site for what cpu you want.

What do you mean last awhile? Not die or stay good enough to play your games at good settings?

I hope you find what you are looking for ,Reaper

Link to post
Share on other sites

Does it even start up? Going into a boot, re-boot cycle?

 

This will happen if clock speeds/heat thresholds changed (any number of reasons), and if you clear your BIOS you can try loading defaults and even underclocking the CPU.

 

If you hit power and nothing happens, might want to check to see if you even have power to the mobo. My motherboard has LEDs as well as GPUs, they will glow green in a Power off state indicating clean power to the mobo.

 

One time I had a 12 volt molex ground pin come out of a socket and touch the case, this prevented it from booting, once I found it, it booted fine. Decent Power Supplies will detect overcurrent and never let you power up.

 

Just some things to check.

Link to post
Share on other sites

Hm before I took out the CPU, the cpu fan was going full throttle if I tried to restart the computer. No display, and the gfx card had a delayed startup. Took the cpu out, put it back in, no powering up even to bios

Link to post
Share on other sites

I concur with tedster - if the computer isn't booting it's not likely the CPU.

 

If nothing happens when you hit the power button - as in the motherboard won't even POST or anything, there's likely a problem with the board. Have you verified the PSU with another computer?

 

Is the PSU turning on?

 

If the PSU is turning on, is there a beep code at all?

 

If there is a beep code, what is it?

 

Does your screen display anything at all?

Link to post
Share on other sites

How would I go about doing that. Everything is fine on the mobo.

 

That's the hard part.  the only way to really show that the CPU isn't working is to drop in a replacement with no other changes.  not booting is definitely a sign something could be wrong with the mobo.  and how did you determine that the mobo is fine?

Link to post
Share on other sites

As Tedster said CPU just don't die. Normally you have a longer period of alerting signals. Motherboards die without a warning. At least this was what happened to me. Change Motherboard and CPU to i5. When you don't go for the fastest ones you can stay in a budget.

Link to post
Share on other sites

Screen has no display, the PSI works when I try the paperclip thing with it (as in put one end on the power cable and one in the ground cable in the main cable that's supposed to connect to the mobo) but will not power on with the power button when plugged into the mobo

Link to post
Share on other sites

that sounds like a mobo issue to me.  CPU's can take MASSIVE amounts of abuse and still keep working.  and statistically, your mobo is much more likely to fail.

Link to post
Share on other sites

Try a different power button switch. Switches die all the time.

 

Alternatively, jumper the mobo and try to boot (shouldn't be too hard since you already know your way around a paperclip). Bridge the power pins on the front IO pin cluster using a screwdriver/paperclip/staple. Consult your manual if you can't find the pins (or if they aren't marked on the mobo itself).

 

fp_header.jpg

Link to post
Share on other sites

Hmm ok so I took my fix card out and cpu to have some space to move cables around, now the power supply turns on with the power button, fan connected to mobo works, No beeping from mobo though

Stays on for about 15-30 seconds, and restarts. Still no display.

Also i don't think my mobo has an LED light.

Link to post
Share on other sites

Hmm ok so I took my fix card out and cpu to have some space to move cables around, now the power supply turns on with the power button, fan connected to mobo works, No beeping from mobo though

Stays on for about 15-30 seconds, and restarts. Still no display.

Then it isn't POSTing, which means your motherboard is toast. Replace that, everything else should be fine.

Link to post
Share on other sites

what is your current model?  that will give everybody an idea of what stuff it has to support.

Link to post
Share on other sites

So my CPU died on me today. Computer just shut off and wouldn't power up again. PSU works fine so I figured it's the CPU after troubleshooting.

I plan on upgrading from the i3 that died to an i5, how should I choose it model wise and how do I buy the correct socket CPU? Obviously going for budget here because I'm poor as fuck, but I don't want it to break o n one year either. This one lasted me a good 6-7 years.

 

 

CPU's are rather resilient, especially the LGA chips (no pins to bend, yay!).

 

As mentioned in above posts, googling the model of your motherboard should tell you the socket.  If it's a seven year old machine, it's probably LGA 1366, the 1st generation of Intel's I series of chips (nahalem, methinks?) which means replacement boards are going to be both 1.) hard to find/expensive 2.) cheap OEM featureless boards.  Which isn't a path I'd recommend.

 

 

Another thing you might try if you haven't already done is to pop the coin cell battery out and reseat it (with power to the machine off of course) or some other way to resetting the CMOS/BIOS, some enthusiast level motherboards have built in reset buttons to clear the CMOS and essentially reset to factory.  Shot in the dark, but worth a shot.

 

 

 

 

*EDIT*

If you're feeling exceptionally brave, you can hook everything up, leave the front panel connectors unplugged and use a small screwdriver to short the power jumpers and see if that's the issue.  (don't recommend this unless you're used to playing around with computery bits)

Edited by _Tsavo_
Link to post
Share on other sites

Meh, I dont find it exciting to break your stuff :^)

 

Sparks and sadness due to magic smoke is never a good thing. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...