Jump to content
StranaMechty

[Solved by who the hell knows] Computer will not stay asleep

Recommended Posts

I'm usually the one doing the tech support, not looking for it. This is weird.

I am experiencing defiant child syndrome and I don't even have a child. I put my desktop into sleep mode when I go to work so I can send a wake on LAN packet and remote into it if I need a way to test things from outside our internal network or retrieve some file.

Windows 7 Pro 64-bit
Asus Z170-P D3 Motherboard
i5-6600k CPU

Machine has just been gutted by PSU failure, so it had a new PSU, motherboard, and processor installed on Monday. Through early Tuesday sleep mode worked fine, but after installing all the hundreds of Windows updates, various bits of software on my fresh Windows install, and overclocking the CPU something went wrong and as of very late Tuesday sleep mode ceased to function properly. The computer will go to sleep and then wake back up within seconds. Hands are entirely off the desk, no movement of the keyboard/mouse.

Event viewer does not help, it simply lists the source as "unknown". An elevated command line query of "powercfg -lastwake" returns no useful information, it doesn't even bother listing a device category that caused the last wake. An elevated command line query of "powercfg devicequery wake_armed" returned four devices as able to wake the computer, the network card and three "HID Keyboard Device <00X>". 

Things I have tried

  • Disabling wake timers in power configuration
  • powercfg devicedisablewake [all devices]
  • GUI disabling of a device's ability to wake the computer
  • Hibernate mode instead of sleep mode (same results, just takes longer to start back up again)


I haven't tried physically unplugging the keyboard/mouse/Ethernet cable, that's on my list when I get back  from work. As a last resort I can do a system restore to Tuesday morning but don't particularly fancy installing 200+ Windows updates and various pieces of software again, particularly if doing so will just cause the issue to arise once more.

All the Google searching I've done only covers finding the device that last woke the computer via the event viewer and then disabling that. Unfortunately, I don't get that information and even after disabling all devices it still happens, and I'm out of ideas.

Share this post


Link to post
Share on other sites

I'm usually the one doing the tech support, not looking for it.

Aaand that's why this is exactly what a "halpplz" thread should look like.

 

Edit: not being completely unhelpful, I'm pondering it.

Share this post


Link to post
Share on other sites

Are the sleep states enabled in the BIOS? It could also be a bug in the BIOS, try updating/downgrading it to a different build. Or something else on the mobo might be at fault, RMA doesn't hurt.

Doesn't sound like a software problem to me since it looks like the chip did indeed go to sleep.

Share this post


Link to post
Share on other sites

I ran through this before. Mine ended up being my Ethernet was waking the system somehow. Had to unplug it, sleep, wake, sleep, wake, then plug it back in. Never had an issue after that.

My guess is one of your plugged in devices is doing something similar.

Share this post


Link to post
Share on other sites

Not sure if you've tried this

This might be a simple solution but easily overlooked:

Step1. Device manager
Step2: Network adapters
Step3: Wifi or ethernet adapter
Step4: Power management.

If they're allowed to wake up the computer - that's your problem.  

Edit: didn't read properly, apparently you did look at it. 

Share this post


Link to post
Share on other sites

First you need to narrow it down. unplug every usb device and your ethernet cable, but leave your mouse, put it to sleep and uplug your mouse as its going to sleep. If it wakes up then there is something wrong with the motherboard or bios. If not slowly begin to plug in usb devices as it goes to sleep to find the culprit. I have seen the second usb on some keyboards thats just for the backlight wake a pc when it was asleep. 

Share this post


Link to post
Share on other sites

This may or may not help you, but I've experienced on 2 occasions the same issue. Both times, the culprit was a piece of software that was running strange "undercover" licensing schedules.

Basically, a software that is on a X day trial calling the mother ship all the time to check for updates.

It did not show up anywhere for me either and I found out about it by sniffing my Ethernet connection for incoming / outgoing connections before / after it went out of sleep mode.

Good luck!

Share this post


Link to post
Share on other sites

My brother has the same issue. When he tries to put his PC into sleep mode it just randomly "wakes up" in a matter of seconds. He found a solution for that and that was unplugging this ethernet cable(or however its called) from the motherboard and then his PC stayed asleep. Weird as fuk if you ask me, but try it out yourself.

Share this post


Link to post
Share on other sites

My brother has the same issue. When he tries to put his PC into sleep mode it just randomly "wakes up" in a matter of seconds. He found a solution for that and that was unplugging this ethernet cable(or however its called) from the motherboard and then his PC stayed asleep. Weird as fuk if you ask me, but try it out yourself.

That occurs when the BIOS has awake over ethernet enabled. Going into settings and change boot to not allowing that should fix that.

Share this post


Link to post
Share on other sites

That occurs when the BIOS has awake over ethernet enabled. Going into settings and change boot to not allowing that should fix that.

I'll tell him to do that and will report back if it works, fenks. :gaben:

Share this post


Link to post
Share on other sites

My brother has the same issue. When he tries to put his PC into sleep mode it just randomly "wakes up" in a matter of seconds. He found a solution for that and that was unplugging this ethernet cable(or however its called) from the motherboard and then his PC stayed asleep. Weird as fuk if you ask me, but try it out yourself.

That occurs when the BIOS has awake over ethernet enabled. Going into settings and change boot to not allowing that should fix that.

StranaMechty clearly says in the OP that the reason he puts his computer to sleep is to be able to access it remotely if need be, which requires WOL. Thus, unplugging the Ethernet cable or disabling WOL is not a solution. It is merely a test: if it works, it means that a piece of software is the source, if it doesn't work, it also means that a piece of software is the source, i.e. the test is irrelevant.

Share this post


Link to post
Share on other sites

 

StranaMechty clearly says in the OP that the reason he puts his computer to sleep is to be able to access it remotely if need be, which requires WOL. Thus, unplugging the Ethernet cable or disabling WOL is not a solution. It is merely a test: if it works, it means that a piece of software is the source, if it doesn't work, it also means that a piece of software is the source, i.e. the test is irrelevant.

I was replying to @Siimcy on his brother's issue, unless he needs to access it remotely also. We're still waiting on the OP's report to see what helped.

@OP, what software do you use to remote in?

Share this post


Link to post
Share on other sites

@OP, what software do you use to remote in?

Wake on LAN packet sender: http://www.depicus.com/wake-on-lan/wake-on-lan-gui.aspx

RDP: http://www.microsoft.com/en-us/download/details.aspx?id=44989

The computer is behind a firewall, I use the OpenVPN server built into my router to access the local network so I needn't publish RDP to the Internet proper.

Share this post


Link to post
Share on other sites

I had a similar issue that was traced back to the MS Office updater. Every time the computer was placed into hibernation mode for the night, the updater would power it back up later to check for Office updates.

Share this post


Link to post
Share on other sites

Have just arrived at home. To cut straight to the heart I unplugged all USB devices and the Ethernet cable, and even the 3.5mm speaker cable, just for shits and giggles. I left the mouse in long enough to click on the sleep button, then pulled it before the computer finished entering sleep, leaving only the three monitors plugged in.

Same behavior.

:welp:

Share this post


Link to post
Share on other sites

Update: I stepped back my overclock to stock values, rebooted, still no change in behavior. Tried disabling a service that always showed up just before the "system has exited sleep mode" message in the event viewer, still no change in behavior. Then the machine blue screened on a reboot prior to which I had selected "boot into safe mode" (it didn't) with a CPU-related error code (101), which gave me the chance to enter safe mode. Turns out there's no sleep in safe mode so that particular test could not be done, so I rebooted without touching anything.

Upon rebooting back into normal mode...it can sleep just fine.

ConfusedLookAround.gif

As the purpose of my overclock (recording Tanks at max graphics in 1920x1200 resolution at 60 FPS with a software encoder) proved unattainable even with the overclock, I think I'll just stick with stock values for the moment, out of a deep superstition that most sysadmins develop.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...