Jump to content
WarshipsToday

Warships Today Rating - a WoWS rating, and warships.today

Recommended Posts

16 hours ago, WarshipsToday said:

Since we don't have per-game info from WG, the granularity is whatever the deltas between snapshots are. If all is working well then it should be close to the 250 and the difference between 242 and 261 in reality is inconsequential.

We have a bunch of things in flight (mostly from stability / ability to grow perspective) that we have to finish before we start adding / changing features. We will have to implement those first.

In many cases, like mine currently, it doesn't pick a value close to 250, it has something like 14 games and then 600 as the next.  Since 14 is closer to 250 than 600, it declares the 14 to be my Recent.

I appreciate the work you do regardless of WG's lack of support and (often) API issues.  If you do find time to add a new feature, I think that having clan tags (if possible now) would be a popular addition to the signature.

Link to post
Share on other sites

How long does it take people to show up on this site?  I've been playing several days and I don't appear at all.

Link to post
Share on other sites
14 hours ago, FlorbFnarb said:

How long does it take people to show up on this site?  I've been playing several days and I don't appear at all.

https://na.warships.today/player/1002832475/FlorbFnarb

Normally you should have been able to find yourself by just typing your username in the search bar and pressing Enter. But we were having some issues with the server.

Link to post
Share on other sites

Hey, first off I am grateful for all the effort you put into the website.  I have a question, two times now my old IJN DD stats have vanished for a couple of weeks, and then reappeared as recents.  I understood it the first time, because of the IJN second DD line changing things up, but it just happened again last week, my stats were minus the IJN DD's for a second time and then got dumped back in as something I did in one day.  Is this all on wargaming, or is it something unique to my account?

Link to post
Share on other sites

The root cause is WG providing the corrupt snapshots without the IJN DDs.

However, us still having these corrupt snapshots in database and being used for some calculations may be a contributing factor.

In an ideal world, we would have cleared those corrupt snapshots from the database, but we are currently facing issues in doing that (basically we could remove them, but recalculating all the values dependent on them would take too long).

We are gradually taking steps to allow to clear them, but we aren't there yet. We will get there eventually.

Link to post
Share on other sites

My numbers appear to fluctuate on a near-daily basis.  I often have a 1640 WTR overall (which is what my number has historically been), and other times it dips down to around 1623.  My total number of battles stays the same, so it doesn't appear to be an issue stemming from the IJN destroyers.  Right now the website profile and signature are giving me two different WTR numbers while keeping win rate, battle count, and average tier the same.

Link to post
Share on other sites

From our side, we haven't forgotten about the fact we have corrupted data in our database (due to WG returning corrupt data) but due to the amount of data stored we are running out of space which limits our options in cleaning it up. We will probably move to a different hosting setup for the data (more expensive, but with better scaleability) and this will allow us to address it. Timeframes probably measured in weeks.

Link to post
Share on other sites

Is there any reason as to why the signatures go from largest to smallest recent values, say 100 days, 60 days, and 14 days, and then has overall at the end? Does it not make more sense to have the most recent period first, and slowly work up to the overall?

Edit: Thanks for fixing what I think is illogical.

Link to post
Share on other sites

Are you guys moving stuff around in your database again? Only I have 7 day stats for the Indy, Belfast and Ibuki in my profile and I've not played randoms since well before last week.

Link to post
Share on other sites

I found another bug.

JSbYQfh.png

This is my NO stats, I noticed this since I got her, there are no average tracked numbers, and the average wtr for her is 0. I haven't noticed it for other ships.

Link to post
Share on other sites

Alas there seems to be aproblem with warships.today and/or WG API. I don't get any result for my account for days now.

Link to post
Share on other sites
On 03/04/2017 at 0:02 PM, Jaegaer said:

Alas there seems to be aproblem with warships.today and/or WG API. I don't get any result for my account for days now.

We had a disk drive crash / corruption / etc. on the WOWS EU database. We have recovered, but while we were down data were not collected. It should gradually return to normal business.

Apologies for the inconvenience.

Link to post
Share on other sites
43 minutes ago, WarshipsToday said:

Apologies for the inconvenience.

Thanks for all your effort.

Link to post
Share on other sites

Apparently my WoWs account is one of the ones that has errors, because I am always getting anomalys between what I did on a given day, and what it says I did.  Hopefully they can at least release a PR rating similar to what they had in tanks.

Link to post
Share on other sites

To clarify a bit, I played two PVP games today, winning both. I did quite well in my Edinburgh and Kutuzov shooting down 38 planes and 58k and 127k damage.  1 hour later I had 3 battles, this AM I have 7 battles played today, 5 Cruiser, 1 DD and 1 BB. with a 71.43% wr, but I have STILL only played two battles today.  The overall battle count is equal to true battlecount on the Wargaming web page and in game, and the overall stats are the same.  I'm guessing the client missed games from a few days ago and is adding them into today's count?

I don't envy trying to sort stuff like this out from their API, do you think they are tracking other things but just not making them available?  In essence attempting to thwart the XVM nightmares from WoT?

Link to post
Share on other sites

Still no French ships; ship images are broken and have been for a few weeks; the website seems to be under heavy load recently and often refuses to work even after refreshing.  Is Warships.Today doing alright?

EDIT:  French ships are finally showing up for me.

Link to post
Share on other sites
11 hours ago, Mesrith said:

Still no French ships

EDIT:  French ships are finally showing up for me.

Yes, we added France as a nation to dropdowns so that they appear. Thanks for letting us know they were missing.

Quote

ship images are broken and have been for a few weeks;

Ship images should also now be fixed.

Quote

the website seems to be under heavy load recently and often refuses to work even after refreshing

What are the symptoms of this? White page? Some error message? Can you send a screenshot + screenshot of the Chrome debug console?

Link to post
Share on other sites

Friday night around 8-9pm EST it would just lock up on me. I'd search for a player, and nothing.  Just spinning progress and it wouldn't move off the home page.  

 

Edit-off topic, just saw that my sig updated with yesterdays stats....looks like I need to play with you more @Mesrith

Edited by map381
Link to post
Share on other sites
21 hours ago, WarshipsToday said:

Yes, we added France as a nation to dropdowns so that they appear. Thanks for letting us know they were missing.

Ship images should also now be fixed.

What are the symptoms of this? White page? Some error message? Can you send a screenshot + screenshot of the Chrome debug console?

It's working for me at the moment, but to give you an idea:

10zs08m.jpg

I'll often (perhaps 30% of the time in recent weeks) search for a player and get the blank loading screen, and after 10-15 seconds the loading text will go away as if it's finished, but it will remain otherwise the same blank screen with only the player's name.  I can refresh multiple times and still get nothing.

Signatures have been crashing fairly regularly, giving just a white image with text along the lines of "the website was unresponsive".

Last week I did not have any daily stats; instead, I had a streak where it would simply add my day to the previous ones, so that I had a 2-day, then a 3-day, all the way up to a 6-day stat line as my lowest interval, despite playing games each day.

I still get an error about once a week where my WTR will drop from its current ~1645 down to the 1620s, on both the website and signature, as if it loaded some older expected values.  My battle count will be correct, so it's not temporarily missing games played.

 

As always, thanks for the timely response and the work that you do.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...