Jump to content

Recommended Posts

Just posted this on the official forum but maybe here the chances of getting actual help are better:

Every patch brings up the same error for me:

When patching, the installer takes the *.xdiff/*.rdiff files from "World_of_Tanks\UpdatesData\client\patch#\res\packages\", applys them to the corresponding *.pkg files in "World_of_Tanks\res\packages" and generates new *.pkg files from it.

 

At least it does that on every PC except mine, somehow the launcher is not able to perform this step on my system and I have no idea why. The logfile (example from todays WoWS patch, its the same for WoT) just reads:

apply bin-diffs. process file: name="basecontent_0001.pkg.0.5.8.0.181621.541DEFF6.rdiff"
06/07/2016 18:04:20 kill safe: rename: file="G:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.8.0.181621_0.5.7.0.177657_sdcontent_na.wgpkg\res_packages\basecontent_0001.pkg", what="rename file", msg=""G:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.8.0.181621_0.5.7.0.177657_sdcontent_na.wgpkg\res_packages\basecontent_0001.pkg" to "G:\Games\World_of_Warships\UpdatesData\sdcontent\wows_0.5.8.0.181621_0.5.7.0.177657_sdcontent_na.wgpkg\res_packages\basecontent_0001.pkg.a505560d.killme"
system error: (0x2)"Das System kann die angegebene Datei nicht finden.""

("Das System kann die angegebene Datei nicht finden." = "file not found" )
The *.rdiff file is there, the old *.pkg file is there, but it fails to create the new *.pkg file from them.
The only way I am able to install the game is to actually install on another PC and copy the ready patched *.pkg files to the UpdatesData\...\ folder on my PC. (Manually creating the *.pkg files and then downloading the already patched *.pkg's via integrity check also works)

Support has not been able to help so far, maybe here someone with a little programming knowledge has an idea?

Link to post
Share on other sites

Have you used "WoT Tweaker" in the past?

 

That aside - did you try downloading the whole client after deleting all WoT files incl. the folder where preferences.xml is located (Sorry dont know the path atm)? How does it behave with a fresh client (patching that one)?

Link to post
Share on other sites

No, never used Wot Tweaker.

When I do a clean install (after deleting tempfiles, appdata files and manually cleaning the registry) it works when the install is from 0 to the latest patch (then there are no *.xdiff/*.riff files but only up-to-date *.pkg files). Unfortunately most of the times that's not the case, it's usually an incremental patch from 0 to older patch# to latest patch# so it brings up the same problem.

Link to post
Share on other sites

Try the following - low chance of success

  • download the latest version of 7zip and install it
  • go to the WoT main folder and cut out the 7z.dll - paste it on your desktop (backup)
  • after that go to the install path of 7zip and make a copy of the 7z.dll and paste it into the WoT main folder
Link to post
Share on other sites

While that doesn't raise my hope too high it's actually related to the problem and makes more sense than anything WG support ever said.

I'll try next patch, thanks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...