Jump to content
TheMarine0341

Easy Slack Notifications For CW

Recommended Posts

So, campaign is coming up. A lot of us use Slack for notifications for CW. If you dont have someone who's really good at it, heres an easy "fix" to integrate slack notifications of CW

First, you're going to add a bot called "Outgoing Web Hooks"

Once thats added, I would suggest creating a new channel called something along the lines of "cw_notifications". Please note, this can NOT be added to a private channel or to slackbot (this isnt fancy, just gets the job done)

Trigger words: I have it set to 'clanwars', but you can have as many or few as you want or need

URL: This is where the 'magic' happens. In this case, the URL calls to ClanTools, then returns the data
https://sv.clantools.us/integrations/battles/report?provider=na&tz=et&service=slack&clan_id=YOUR_CLAN_ID
To find your clan ID, over at Wargaming.net sign in, click on your profile, and select "My Clan". In the URL, your clan ID number is right after /wot/ in the URL. In our (VILIN) case, for example, its 10000002161. You'll probably need to change this for EU/RU/SEA clans (probably the provider=na and your time-zone tz=et)

Token: Generated by your slack to verify its your slack

Everything else is pretty self-explanatory. If I notice any mistakes I'll correct that, as Im not the one who initially set this up only copying someone else's work (Thanks SideFlanker!)

This is what it will look like in channel

9WgKpAA.jpg

Share this post


Link to post
Share on other sites

Doesn't seem to be working for EU, it just says this

{"username":"Clan Tools","icon_url":"https://clantools.us/150x150.png","text":"*Error:* Received Invalid Stronghold Data from WG API"}

:doge:

Share this post


Link to post
Share on other sites
On 11/2/2016 at 9:40 AM, TheMarine0341 said:

@_Steve I only took a shot in the dark for EU integration, not sure what all would need to change

 

On 11/1/2016 at 0:06 PM, _Steve said:

Doesn't seem to be working for EU, it just says this


{"username":"Clan Tools","icon_url":"https://clantools.us/150x150.png","text":"*Error:* Received Invalid Stronghold Data from WG API"}

:doge:

I'm getting a similar problem on NA right now. @TheMarine0341 Do you have this on your end? 

Never mind. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...