Jump to content
Rexxie

CPU Usage and Mouse Polling

Recommended Posts

Quick summary:

My CPU (Ryzen 3 1200) is being obliterated by my mouse (Steelseries Rival 300). By how much is highly dependent on what I set my mouse polling rate to; moving the mouse causes a minimum of a 10% jump in CPU usage at a 125hz polling rate, up to ~30% CPU usage at 1000hz.

I'm confused because by all accounts I've read, mouse polling rate should cause next to no impact on performance. I am using the basic mouse drivers along with steelseries engine (steelseries' mouse settings software). I've also made sure it's actually causing performance issues in applications; my framerate in anything CPU-bottlenecked drops by that same 10-30%, dependent on polling rate.

For now I've just set my polling rate to 125hz, but I'm honestly curious what is actually going on here. I have never heard of a modern CPU having this kind of issue. I also have a friend with the same mouse who also sees relatively the same CPU usage and FPS drops when moving their Rival, so my first bet would be a pretty horrible bug in an relatively common mouse.

 

(Win10, no over/underclocking, on an RX480, mouse is wired via USB3)

Share this post


Link to post
Share on other sites

ASRock AB350 Pro 4, I haven't installed any of the mobo BIOS updates, if that's what you mean? I could try that, but I haven't noticed anything else off & think any BIOS updates my board has are more for better memory support.

Share this post


Link to post
Share on other sites

Unfortunately it doesn't seem like it, there's nothing USB-related in there, just a lot of tools and drivers if you happen to use some very specific hardware setups. I'd be surprised if its actually my USB controller, my girlfriend has the same issue with a different mobo but same mouse.

edit:

Some more weird tidbits, this only happens when the mouse is moving on the main monitor. Moving it on my secondary monitor causes no real CPU usage.

edit edit:

Also somewhat worryingly, I see a ton of people mentioning this problem online, but not a single conclusive fix being posted. Ouch. Doesn't seem related to the mouse at all, this probably isn't something I'm going to be able to fix.

Share this post


Link to post
Share on other sites

Steelseries Malware, fam. 
yeah i know dontclickdumbshit.exe is the best antivirus out there but disconnect it from the internet and retest.

Share this post


Link to post
Share on other sites

Do you have some special SS driver/program installed? Maybe it's that fucking up, artificially cranking up the polling rate via driver instead of letting the mouse hardware handle it. Check if there are options to unload settings onto the mouse (my Logitech can do this).

Share this post


Link to post
Share on other sites

Update BIOS, update all mobo related drivers - that 's all you can do beside getting rid of that mouse and the SS drivers (may need fresh Windows install ...). Haven't heard of shit like that in ages

Share this post


Link to post
Share on other sites

Try run Task Manager while running the game, you can check CPU usage there to find the culprit

If it runs better with Task Manager open, congratulations you've got malware/virus.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...